Author Topic: Unable to change set points on a Trane Z-wave thermostat  (Read 4789 times)

Walken100

  • Full Member
  • ***
  • Posts: 190
    • View Profile
Unable to change set points on a Trane Z-wave thermostat
« on: May 13, 2012, 09:58:56 am »
Ok, before you added increased support to z-wave thermostats I was able to change my set points. Now I can't.  I started to make this a bug report but figured I'd ask first.

Background
- My system has been dead for a few months (computer died) and I just recently reestablished my system on a new computer and upgraded so I may have screwed something up in the process.
- The thermostat works (I can change set points) when controlled with Think Essential software and a ControlThink stick. I use the Vizia serial controller with Elve.
- Mode changes work great
- I can't change set points using  Elve Management studio by invoking methods from the Device methods tab of the Z-wave device
- I'm getting lots of debug statements logged against the z-wave driver

Thoughts?

Bart

Bart
So tell me again why I have a right half of my brain?

John Hughes

  • Administrator
  • Hero Member
  • *****
  • Posts: 2851
    • View Profile
    • Codecore Technologies
Re: Unable to change set points on a Trane Z-wave thermostat
« Reply #1 on: May 14, 2012, 12:20:08 pm »
It's possible that that broke after the z-wave driver rework.

I would like to see some snippets from the log.

Please turn on diagnostic debugging for the device in Elve, then attempt to control the thermostat set points and not the date/time.  Go to the log and copy and paste the entries for that driver around that time into a post.

Thanks.
John Hughes
Codecore Technologies

Walken100

  • Full Member
  • ***
  • Posts: 190
    • View Profile
Re: Unable to change set points on a Trane Z-wave thermostat
« Reply #2 on: May 15, 2012, 06:24:38 pm »
The log below represents two mode changes and two attempts to change set point. One in cooling mode and one in heating mode. Sorry for the long post.


2012-05-15 12:09:00.4662488Z
Debug
>?N5<CR>
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:09:00.5013454Z
Debug
<E000
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:09:00.6714258Z
Debug
<X000
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:09:00.8303339Z
Debug
<N005L000
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:09:22.6743146Z
Debug
>N9SE67,1,1,1,23<CR>
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:09:22.7261224Z
Debug
<E000
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:09:23.1559919Z
Debug
<X000
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:09:45.7895150Z
Debug
>?N6<CR>
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:09:45.8272319Z
Debug
<E000
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:09:45.8707278Z
Debug
<X000
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:09:45.8994159Z
Debug
<N006L000
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:09:48.5968894Z
Debug
>N9SE64,1,2<CR>
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:09:48.6435867Z
Debug
<E000
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:09:51.2912147Z
Debug
<X000
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:10:15.8392473Z
Debug
>N9SE67,1,2,1,17<CR>
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:10:15.8910891Z
Debug
<E000
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:10:16.3576482Z
Debug
<X000
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:10:19.4104549Z
SystemMessage
Executing rule 'Living room motion' asynchronously.
MasterService
TAYLOR_CONTROL
None



2012-05-15 12:10:19.4114242Z
SystemMessage
livingroom motion
MasterService
TAYLOR_CONTROL
None



2012-05-15 12:10:19.6249339Z
SystemMessage
Executing rule 'Living room motion' asynchronously.
MasterService
TAYLOR_CONTROL
None



2012-05-15 12:10:19.6254872Z
SystemMessage
livingroom motion
MasterService
TAYLOR_CONTROL
None



2012-05-15 12:10:30.9878109Z
Debug
>?N7<CR>
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:10:31.0254162Z
Debug
<E000
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:10:31.0689567Z
Debug
<X000
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:10:31.0970289Z
Debug
<N007L000
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:10:32.5632497Z
SystemMessage
Executing rule 'Living room motion' asynchronously.
MasterService
TAYLOR_CONTROL
None



2012-05-15 12:10:32.5639459Z
SystemMessage
livingroom motion
MasterService
TAYLOR_CONTROL
None



2012-05-15 12:10:32.7790909Z
SystemMessage
Executing rule 'Living room motion' asynchronously.
MasterService
TAYLOR_CONTROL
None



2012-05-15 12:10:32.7797290Z
SystemMessage
livingroom motion
MasterService
TAYLOR_CONTROL
None



2012-05-15 12:10:54.5360228Z
Debug
>N9SE64,1,1<CR>
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:10:54.5821435Z
Debug
<E000
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:10:59.3404652Z
Debug
<X000
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:11:16.2054721Z
Debug
>?N8<CR>
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:11:16.2505538Z
Debug
<E000
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:11:16.3675430Z
Debug
<X000
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:12:01.4842426Z
Debug
>N9SE49,4<CR>
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:12:01.5279308Z
Debug
<E000
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:12:02.3658174Z
Debug
<X000
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:12:02.4864635Z
Debug
>N9SE64,2<CR>
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)


2012-05-15 12:12:02.5297164Z
Debug
<E000
DriverService
TAYLOR_CONTROL
Driver
Z-Wave (ViziaRF RZC0P/VRC0P) : Z-Wave (ViziaRF RZC0P/VRC0P)



Bart
So tell me again why I have a right half of my brain?

John Hughes

  • Administrator
  • Hero Member
  • *****
  • Posts: 2851
    • View Profile
    • Codecore Technologies
Re: Unable to change set points on a Trane Z-wave thermostat
« Reply #3 on: May 16, 2012, 08:49:43 am »
Excellent, it's the command with SE67 that I will be looking at.

Do you recall the exact temperature you were setting it to and are you using Fahrenheit or Celsius.

Also how are you setting it?  Via a touch screen offset button, a script, or via EMS?

If you are unsure of the above please rerun the test but use the Methods tab in EMS and select the SetThermostatHeatSetPoint method and press the invoke button. I only need the SE67 line.

Thanks
« Last Edit: May 16, 2012, 08:57:11 am by John Hughes »
John Hughes
Codecore Technologies

John Hughes

  • Administrator
  • Hero Member
  • *****
  • Posts: 2851
    • View Profile
    • Codecore Technologies
Re: Unable to change set points on a Trane Z-wave thermostat
« Reply #4 on: May 16, 2012, 09:04:36 am »
Nevermind on the above.

It looks like it is working correctly, however the driver now sends the temperature to the thermostat in celcius.

You would assume that they would all support celcius but perhaps not. I may need to change it to use the mode you selected in the driver settings.

What is the model # of the Trane thermostat you are using?
« Last Edit: May 16, 2012, 09:27:19 am by John Hughes »
John Hughes
Codecore Technologies

John Hughes

  • Administrator
  • Hero Member
  • *****
  • Posts: 2851
    • View Profile
    • Codecore Technologies
Re: Unable to change set points on a Trane Z-wave thermostat
« Reply #5 on: May 16, 2012, 05:31:22 pm »
I posted a quick patch version (download the latest trial version and install) which hopefully fixes this issue.

Please let me know.
John Hughes
Codecore Technologies

Walken100

  • Full Member
  • ***
  • Posts: 190
    • View Profile
Re: Unable to change set points on a Trane Z-wave thermostat
« Reply #6 on: May 16, 2012, 06:55:09 pm »
Fixed!

If it means anything in a past life I ran into the same issue with commercial controllers. Needed to send and receive in the local system of choice.

Thank you.

Bart
Bart
So tell me again why I have a right half of my brain?

John Hughes

  • Administrator
  • Hero Member
  • *****
  • Posts: 2851
    • View Profile
    • Codecore Technologies
Re: Unable to change set points on a Trane Z-wave thermostat
« Reply #7 on: May 17, 2012, 08:34:41 am »
Excellent!
John Hughes
Codecore Technologies