Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - John Hughes

Pages: [1] 2 3 ... 171
1
General Discussion / Re: What's next?
« on: January 05, 2017, 07:06:28 pm »
An analysis of the code and various open source licenses would need to take place to ensure there are not conflicts with open source licenses.

Additionally I think a few drivers which require 3rd party installations would need to be removed... possibly just JR Media Center  Active Home SDK.

Modifications might also be needed to get it to compile in more recent versions of visual studio and .net libraries.

Releasing the source could also expose any "potential" security vulnerabilities.

2
General Discussion / What's next?
« on: September 11, 2016, 05:49:32 pm »
All,

As you are aware, development on the Elve platform has been in hibernation for some time due to competing priorities. I am flattered by the emails I still receive about moving development forward, open sourcing and other product venture ideas. As honored as I am, my availability just doesn't permit me to be as effective as I would like in even coordinating an effort to take the next steps.

I'm certainly open to discussion on a collaborative effort on moving to next steps but I would need to take a mostly hands off approach.

Thanks so much for your support!

John

3
General Discussion / Re: IOS App
« on: September 11, 2016, 05:41:44 pm »
All, I kept the Apple Developer account operational for some time after version 2 was released and made free. A year or so later I let the Apple Developer account lapse since I am no longer developing on the platform and therefore Apple removed from the App Store. I am sorry for any inconvenience this has caused.

I'll be posting a followup in another post shortly.

John

4
General Discussion / Re: The future of Elve
« on: July 13, 2015, 09:21:37 pm »
... pondering open sourcing portions of the code at this point. I just don't have the time to make it completely open source compliant. :/

5
Elve Version 2.1 Beta / Re: Elve 2.1 Beta Download
« on: December 01, 2014, 06:50:17 am »
All,

Just a quick note before the more public announcement... Elve 2.2 has been released and includes a major bug fix...

* Fixed Rules issue that caused some rules to be triggered when a property index value changed even if the rule was for a different index than the rule specified.
* Fixed an error that could occur when attempting to edit a rule which had a blank property index.
* Fixed issues with the Google Contacts driver.

6
Elve Version 2.1 Beta / Re: Elve 2.1 Beta Download
« on: July 07, 2014, 07:08:43 pm »
...If you want to send me the latest HAI driver I can take a look at fixing the issues above, start issues, etc.

I have sent you the HAI driver source, thanks again!!!

7
Elve Version 2.1 Beta / Re: Elve 2.1 Beta Download
« on: July 07, 2014, 03:10:06 pm »
Seeing something else very odd with 2.1 and the HAI driver.  Whenever any zone status changes rules are firing for unrelated zones and even unrelated functions.

Here is an example:
I have a rule that starts a timer when the front door is open
I have a rule that starts a timer when the mudroom door is open
I have a rule that sends a UPB link on a different network when the light level of a unit changes.

I look in my log and all three rules just fired when I opened the guest room door - which has no rules associated with it.

John -
  Finished fixing the Google Calendar Driver.. If you want to send me the latest HAI driver I can take a look at fixing the issues above, start issues, etc.

Thank you. I probably won't be able to get to this until Tuesday night. Thanks again.

8
Bug Reports / Re: Google Contacts Driver - Doesn't Support SSL
« on: July 07, 2014, 03:06:57 pm »
Thank you

9
Elve Version 2.1 Beta / Re: Elve 2.1 Beta Download
« on: July 06, 2014, 07:41:55 am »
Found out why (sort of) my Omni rules aren't firing off. See attached.

I'm getting this whenever I click on an Omni rule in EMS Rules. All but one actually, and that one seems to work fine.
thought maybe they needed the newest dll so I put that back in but I still get the error. Funny thing is now I'm not getting the "retrying" but it hasn't been a long time yet since I put the new dll back. I'll keep an eye on it, just wondering if all the HAI rules need to be remade when using the newer dll's?? Maybe that's causing the disconnects? Just a thought at the moment, I'll update when I can.

Anyway I can get these rules back though?? Right now they come up blank. Not sure if I remember them all. I tried importing them through EMS but I get the same thing.

Is anyone else able to reproduce this error (the FormatException error window Frunple posted above)? I saw mention of it with regards to the omni and elk drivers but I have not been able to reproduce it. If you have a masterserver.config file that has this issue please send me the file and I can fix it.

Thanks

10
Elve Version 2.1 Beta / Re: Elve 2.1 Beta Download
« on: July 04, 2014, 05:04:34 pm »
The rules issue doesn't sound good... Is anyone able to send me their master config file from when the issue was occurring.  I don't recall a breaking change in that area.

11
Elve Version 2.1 Beta / Re: Elve 2.1 Beta Download
« on: July 03, 2014, 03:12:54 pm »
Please try restarting the driver via elve management studio occasionally to see if it works sometimes... Perhaps the logging fix is coincidental.

12
Elve Version 2.1 Beta / Re: Elve 2.1 Beta Download
« on: July 02, 2014, 08:24:45 pm »
Here is the rundown on the HAI.Controller.dll file. Keep in mind this file is provided by HAI and I do not have any control of it's behavior or stability.
  • Elve v1.5 included HAI.Controller.dll v1.0.0.3
  • Elve v2.0 included HAI.Controller.dll v3.9.0.7
  • Elve v2.1 included HAI.Controller.dll v3.9.0.7
  • Latest on HAI Website: v3.11.4.17 dated  05/14/2013

Frunple, you could try stopping the Elve Driver Service, swapping in the older HAI.Controller.dll file from Elve v1.5 or even the latest one, then starting the Elve Driver Service.  I don't know that either will work at all if any better but it would be worth a try. If the latest version seems to work I will be happy to rebuild Elve using it.

I have attached all the versions of the dll to this message as a zip file.

13
Elve Version 2.1 Beta / Re: Elve 2.1 Beta Download
« on: July 02, 2014, 06:51:08 am »
The driver did have some changes but it wasn't obvious if or how those may have caused the issues being reported.

Please keep in mind that the HAI driver uses HAI's .NET API DLL, not a direct connection through the driver.... And HAI's API is terrible... In the past I indicated that it was less than desirable in an attempt to be polite... but it really is very poorly written and architected by HAI... forgive me for my directness.

I don't recall if v2.x includes a newer version of the HAI API DLL file but I will check.

14
Elve Version 2.1 Beta / Re: Elve 2.1 Beta Download
« on: July 01, 2014, 04:26:15 pm »
...also I took a quick look at the difference between the two driver versions and I didn't see any obvious causes for you v2 HAI driver issues.

15
Elve Version 2.1 Beta / Re: Elve 2.1 Beta Download
« on: July 01, 2014, 04:22:30 pm »
Frunple, is the screenshot above from v1.5 or v2.0?

Pages: [1] 2 3 ... 171