Configuration > Web Browser Interface

web interface confusion

(1/3) > >>

dvand:
I'm having trouble understanding what's going on here.

I'm using this script to output the "state" of two of my outputs:

<html>
<body>
<%
names = elkm1.OutputNames;
states = elkm1.OutputStates;
Response.Write(states[64]);
Response.Write("<br>");
Response.Write(states[17]);
%>
   </body>
</html>


Output 64 and 17 should be false. When i run the script i get this answer:

true
false

I've validated that output 64 IS false per the attached screen shot.

Any clue what could be happening?




iostream212:
Is that the whole script?
What happens when you set the output to true and run the script? What happens when you set it to false and run the script?

Sent from my Galaxy Nexus using Tapatalk 2

dvand:
Yes, it's just a test script so i've boiled it down to just that to try and troubleshoot.

Doesn't matter what i set the outputs to - the script always gives the same answer.

I tried it in the script tester and that gives the correct answer.

I'm completely stumped.

Side note: The default test web page also gives the wrong value for climate setpoint. It's like the values are cached somewhere or something.

iostream212:
That is a stumper. You try to restart the driver? I know the values are cached. You right click in the viewer app to see diagnostics and cached values. I would make some elk updates while viewing the properties in the management studio to make sure it is updating properly. Outside of that any chance there is an issue with the script code?

Sent from my Galaxy Nexus using Tapatalk 2

dvand:
Here is another result right from one of the default webpages, the Current temp should be the same as the heat set point. I've made changes using my ipod and eK Pro while watching in the management studio and everything updates fine.

Main
Refresh


Elk M1
Home
Current: 71°
Fan: Auto
Hold: true
Mode: Heat
Cool Set Point: 78°- +
Heat Set Point: 66°- +

Navigation

[0] Message Index

[#] Next page

Go to full version