Author Topic: TS builder: Keyboard shortcuts dor't work occasionally  (Read 4375 times)

valtonen

  • Full Member
  • ***
  • Posts: 217
    • View Profile
TS builder: Keyboard shortcuts dor't work occasionally
« on: May 06, 2010, 12:42:36 am »
Hi,

Pressing Ctrl+C and Ctrl+V for copy-pasting objects works most of the time, but a couple of times I have run to these problems:

1) Pressing Ctrl+C and Ctrl+V does not copy anything, right clicking and selecting 'Copy' and 'Paste' still works well.
2) Selecting an object and pressing Ctrl+C and Ctrl+V does not copy the selected object but copies the two previously selected and copy-pasted objects.

I have not been able to regenerate these intentionally so that I could say what needs to be done that it happens, but will write more if I can regenerate them. Usually I have been doing some property editing and alignments with these labels in between copy-pasting. Restarting of the TS builder has always cured the problem.

-Miika

Frunple

  • Hero Member
  • *****
  • Posts: 774
    • View Profile
Re: Ctrl+C and Ctrl+V copy-pasting errors
« Reply #1 on: May 06, 2010, 05:23:20 am »
Finally someone else seeing this same issue.
I reported this a while back about the delete button but no one else could recreate.
I think the problem is a focus issue. What I mean is, if you are working on a TS, and you shift focus over to another window (any app), then you go back to the TS and click on a menu FIRST, the menu will not open. You will have to first shift focus back to the builder by clicking on it anywhere, then click the menu.
This seem to cause the keyboard shortcuts not to work unless you first click on the builder.
It's not just copy/paste by the way, It's all menu shortcuts.

hpservertech

  • Jr. Member
  • **
  • Posts: 66
    • View Profile
Re: Ctrl+C and Ctrl+V copy-pasting errors
« Reply #2 on: May 06, 2010, 07:02:35 pm »
I have noticed this as well.  Usually when I'm paying attention it does this after my laptop goes to sleep.  Laptop is used for building the screens & view testing.
Current setup: Windows 7 Enterprise x86, x10 cm15a, dedicated master server, dedicated WHS for media

valtonen

  • Full Member
  • ***
  • Posts: 217
    • View Profile
Re: Ctrl+C and Ctrl+V copy-pasting errors
« Reply #3 on: May 07, 2010, 12:07:09 am »
I think the problem is a focus issue. What I mean is, if you are working on a TS, and you shift focus over to another window (any app), then you go back to the TS and click on a menu FIRST, the menu will not open. You will have to first shift focus back to the builder by clicking on it anywhere, then click the menu.

I think I understand what you mean. Other apps open their menu directly if you click over the menu even if the application does not have focus at the time of the first click, but TS builder does not. However, I don't see this as a real problem at least in my usage, because I usually activate the app window before I use it (e.g. with Alt+Tab or clicking it from the Windows taskbar).

Quote
This seem to cause the keyboard shortcuts not to work unless you first click on the builder.
It's not just copy/paste by the way, It's all menu shortcuts.

I was not able to regenerate this problem by switching the focus to some other window and back.

-Miika

John Hughes

  • Administrator
  • Hero Member
  • *****
  • Posts: 2852
    • View Profile
    • Codecore Technologies
Re: Ctrl+C and Ctrl+V copy-pasting errors
« Reply #4 on: May 19, 2010, 10:40:49 pm »
This one is an odd one.

If you are able to reliably reproduce it please post the exact steps.

Thanks
John Hughes
Codecore Technologies

John Hughes

  • Administrator
  • Hero Member
  • *****
  • Posts: 2852
    • View Profile
    • Codecore Technologies
Re: Ctrl+C and Ctrl+V copy-pasting errors
« Reply #5 on: June 12, 2010, 04:05:20 pm »
I recently experienced this as well but I can not for the life of me reproduce it.

Regrading:
Quote
2. Selecting an object and pressing Ctrl+C and Ctrl+V does not copy the selected object but copies the two previously selected and copy-pasted objects.
More than likely it's actually just not copying at all so the clipboard still contains the previous contents.

If anyone is able to get more details on this please let me know.

Thanks
John Hughes
Codecore Technologies

John Hughes

  • Administrator
  • Hero Member
  • *****
  • Posts: 2852
    • View Profile
    • Codecore Technologies
Re: Ctrl+C and Ctrl+V copy-pasting errors
« Reply #6 on: September 04, 2010, 04:47:36 pm »
Is anyone still seeing this issue?
John Hughes
Codecore Technologies

valtonen

  • Full Member
  • ***
  • Posts: 217
    • View Profile
TS builder: Keyboard shortcuts dor't work occasionally
« Reply #7 on: October 13, 2010, 03:54:51 am »
When designing a TS, shortcut keys like 'Delete', 'F4', 'Ctrl+C', 'Ctrl+V', etc. stop sometimes working. And sometimes they start working again after a while of designing a TS. For example, today I have experienced this not-working state perhaps three times in 1.5 hours of TS design.

I have not been able to replicate the issue intentionally.

Reboot of TS builder helps.

-Miika

John Hughes

  • Administrator
  • Hero Member
  • *****
  • Posts: 2852
    • View Profile
    • Codecore Technologies
Re: TS builder: Keyboard shortcuts dor't work occasionally
« Reply #8 on: October 13, 2010, 10:14:01 am »
When designing a TS, shortcut keys like 'Delete', 'F4', 'Ctrl+C', 'Ctrl+V', etc. stop sometimes working. And sometimes they start working again after a while of designing a TS. For example, today I have experienced this not-working state perhaps three times in 1.5 hours of TS design.

I have not been able to replicate the issue intentionally.

Reboot of TS builder helps.

-Miika


This is a duplicate of your "Ctrl+C and Ctrl+V copy-pasting errors" post so I have merged them.

We have not yet been able to duplicate the issue but are looking into it. Any additional information would be great, thanks.
John Hughes
Codecore Technologies

valtonen

  • Full Member
  • ***
  • Posts: 217
    • View Profile
Re: TS builder: Keyboard shortcuts dor't work occasionally
« Reply #9 on: October 13, 2010, 10:32:27 am »
When designing a TS, shortcut keys like 'Delete', 'F4', 'Ctrl+C', 'Ctrl+V', etc. stop sometimes working. And sometimes they start working again after a while of designing a TS. For example, today I have experienced this not-working state perhaps three times in 1.5 hours of TS design.

I have not been able to replicate the issue intentionally.

Reboot of TS builder helps.

-Miika


This is a duplicate of your "Ctrl+C and Ctrl+V copy-pasting errors" post so I have merged them.

We have not yet been able to duplicate the issue but are looking into it. Any additional information would be great, thanks.

Yes, you are right. I forgot this earlier post. Sorry for that.

-Miika