Author Topic: Elve 2.1 Beta Download  (Read 28998 times)

John Hughes

  • Administrator
  • Hero Member
  • *****
  • Posts: 2852
    • View Profile
    • Codecore Technologies
Elve 2.1 Beta Download
« on: June 22, 2014, 01:55:32 pm »
The Version 2.1 beta is a minor update to the Version 2.0 beta, but has the licensing and anti-piracy logic removed.

THIS IS A FREE VERSION OF ELVE. So please note that the license agreement has changed.

While this version does support upgrading from previous versions and I believe this is as stable as the version 2.0 beta, it is recommended that you install this on a non-production machine until it has been more thoroughly tested by the community.

There are also some breaking changes that could potentially affect you. Please see the Change History page for more breaking changes information. Please note that the POP3, Proximity, and Wiimote drivers are no longer included in Elve.

The 2.0 Feature List can still be viewed HERE.

Since Version 2.2 has been released, the 2.1 Beta is no longer available for download.

Google Chrome users: Do not use Chrome to download, it incorrectly blocks the download.

I will be posting the current beta download in this FIRST post only.
« Last Edit: December 01, 2014, 06:36:04 am by John Hughes »
John Hughes
Codecore Technologies

iostream212

  • Sr. Member
  • ****
  • Posts: 459
    • View Profile
Re: Elve 2.1 Beta Download
« Reply #1 on: June 22, 2014, 03:10:36 pm »
Great start.  Looking forward to installing the new version and am excited about the future.  Thank you John!

Sent from my SCH-I545 using Tapatalk

I always wanted to be somebody. In retrospect, I think I should have been more specific.

Frunple

  • Hero Member
  • *****
  • Posts: 774
    • View Profile
Re: Elve 2.1 Beta Download
« Reply #2 on: June 23, 2014, 12:45:06 pm »
I second that! Thanks a lot John!

hdjii

  • Jr. Member
  • **
  • Posts: 99
    • View Profile
Re: Elve 2.1 Beta Download
« Reply #3 on: June 24, 2014, 07:55:20 pm »
Agreed. Thanks a lot.

Howard

iostream212

  • Sr. Member
  • ****
  • Posts: 459
    • View Profile
Re: Elve 2.1 Beta Download
« Reply #4 on: June 26, 2014, 08:04:22 am »
Upgraded to 2.1 in place just fine. Can you check the elk send raw command? I'm still getting the command decorated in quotation marks in the log. Thank you.
I always wanted to be somebody. In retrospect, I think I should have been more specific.

John Hughes

  • Administrator
  • Hero Member
  • *****
  • Posts: 2852
    • View Profile
    • Codecore Technologies
Re: Elve 2.1 Beta Download
« Reply #5 on: June 26, 2014, 05:44:49 pm »
I verified that the Chrome web browser is incorrectly reporting the download as malicious. It is not malicous and I have verified with 3 different anti-virus and anti-malware software. I re-zipped the files and I still get the same result. After doing a small amount of research it looks like Chrome "likes" popular sites, sites with ssl downloads, and or signed executable files, etc.  I'll hold off on doing anything more at the moment, but for those of you using Chrome, please use a different browser to download the installer.

Thanks
« Last Edit: June 26, 2014, 06:07:07 pm by John Hughes »
John Hughes
Codecore Technologies

John Hughes

  • Administrator
  • Hero Member
  • *****
  • Posts: 2852
    • View Profile
    • Codecore Technologies
Re: Elve 2.1 Beta Download
« Reply #6 on: June 26, 2014, 06:03:29 pm »
Wow, I just looked at the v2.1 download log and noticed an impressive download count just within the 1st couple days!!

If you have the time and energy please feel free to post the news on other general automation forums... as I have not yet had a chance to write up a press release.

Thank you for your support.
John Hughes
Codecore Technologies

bpwwer

  • Full Member
  • ***
  • Posts: 220
    • View Profile
Re: Elve 2.1 Beta Download
« Reply #7 on: June 26, 2014, 08:55:24 pm »
I verified that the Chrome web browser is incorrectly reporting the download as malicious. It is not malicous and I have verified with 3 different anti-virus and anti-malware software. I re-zipped the files and I still get the same result. After doing a small amount of research it looks like Chrome "likes" popular sites, sites with ssl downloads, and or signed executable files, etc.  I'll hold off on doing anything more at the moment, but for those of you using Chrome, please use a different browser to download the installer.

Thanks

Chrome on Linux works fine. I've tried a couple of times and have no problems downloading 2.1.

Frunple

  • Hero Member
  • *****
  • Posts: 774
    • View Profile
Re: Elve 2.1 Beta Download
« Reply #8 on: June 27, 2014, 06:09:37 am »
You can still download it with Chrome. Just click the "show downloads" link, then it gives the option to "recover file" then "hurt me plenty" and it's yours.

John Hughes

  • Administrator
  • Hero Member
  • *****
  • Posts: 2852
    • View Profile
    • Codecore Technologies
Re: Elve 2.1 Beta Download
« Reply #9 on: June 27, 2014, 06:26:53 pm »
I posted a new version (v2.1.0.1) which fixes the SendRawCommand() Elk M1 driver method.
John Hughes
Codecore Technologies

Frunple

  • Hero Member
  • *****
  • Posts: 774
    • View Profile
Re: Elve 2.1 Beta Download
« Reply #10 on: June 27, 2014, 06:55:55 pm »
Having all kinds of problems with the new beta. Posted on cocoontech:
"I just installed the newest beta and it's doing the same thing as the 2.0 beta as far as the Omni goes. Just constant disconnects/reconnects.
 
Anyone else seeing this?? This is why I went back to 1.5 from 2.0.
 
Did everyone "upgrade" or do a uninstall/install?"

Since then I've uninstalled all, then did a fresh install. This results in no connection to the master service at all even though it is running and the firewall is off.

I've also tried the latest version with same results.
Anyone else seeing this??


Just went back to 1.5 and still no connection.
Any ideas?


Got 1.5 installed and working. Did an upgrade to 2.1.0.1 and back to the Omni disconnects.
« Last Edit: June 27, 2014, 08:06:01 pm by Frunple »

Frunple

  • Hero Member
  • *****
  • Posts: 774
    • View Profile
Re: Elve 2.1 Beta Download
« Reply #11 on: June 28, 2014, 04:24:02 am »
I got the omni working since last night but I am getting this error when using the activate.Task method:

Date:     6/28/2014
Time:     6:58:05 AM
Severity: Error
Source:   DriverService
Computer: OPTIPLEX755
Context Type: Driver
Context Name: HAI Omni Pro II : HAI Omni Pro II
Description:
There is a bug in a driver... The driver attempted to process a device property change notification for a property named 'LightLevels' however the passed in value of '-97' is outside the range specified in the property's ScriptObjectProperty attribute.


Frunple

  • Hero Member
  • *****
  • Posts: 774
    • View Profile
Re: Elve 2.1 Beta Download
« Reply #12 on: June 30, 2014, 05:26:35 am »
Woke up and couldn't connect. Checked the log and got the attached picture.

Is anyone else having constant issues with the Omni driver or is this just me?
Just started with version 2.

Frunple

  • Hero Member
  • *****
  • Posts: 774
    • View Profile
Re: Elve 2.1 Beta Download
« Reply #13 on: June 30, 2014, 06:00:53 am »
Here's another one...

Just with version 2 again.
I connect over a vpn from work to home. Elve TS viewer worked just fine this way with 1.5. Now I get this:

Date:     6/30/2014
Time:     8:55:52 AM
Severity: Fatal
Source:   TouchScreen
Computer: INSPIRONE1505
Context Type: None
Context Name:
Description:
Failed to initiate remoting.  The touch screen can not be started.The requested address is not valid in its context



What would be causing this? I tried changing machine settings on both, remote and server. Makes no difference.

Cancel this one. Started working after a reboot of the remote pc.
« Last Edit: June 30, 2014, 06:07:02 am by Frunple »

Frunple

  • Hero Member
  • *****
  • Posts: 774
    • View Profile
Re: Elve 2.1 Beta Download
« Reply #14 on: July 01, 2014, 12:28:02 pm »
This is getting bad....