Author Topic: Cancel Doesn't Cancel  (Read 779 times)

HobbyBoards

  • Jr. Member
  • **
  • Posts: 45
    • View Profile
Cancel Doesn't Cancel
« on: July 17, 2010, 12:40:06 pm »
I'm starting to play around with Elve and I ran into a problem. I went into the Device Configuration tab and changed the Scripting Identifier. When I clicked Save I got an error about the identifier already being used so I tried to click Cancel. I then got the same error message. If I am canceling the changes then it should not do any error checking.

Eric

John Hughes

  • Administrator
  • Hero Member
  • *****
  • Posts: 2851
    • View Profile
    • Codecore Technologies
Re: Cancel Doesn't Cancel
« Reply #1 on: July 17, 2010, 02:07:03 pm »
The field validation is occurs as soon as you leave the field as opposed to when you click save or cancel.

Elve is checking the field value when the field looses focus, ie as soon as the cursor leaves the text field (and before the cancel button press is recognized) ... technically speaking Elve never sees you clicking the Cancel button in this case.

This is how it was designed to work so this isn't really a bug, but we can take another look at this down the road.

Thanks.
John Hughes
Codecore Technologies