Configuration > Web Browser Interface

Need a little help getting iPhone going

(1/5) > >>

DaveB:
I previously had my iPhone connected to Elve.  I am running Windows 7 with IIS 7.5 and .net framework 4.   At some point it failed and I am just getting back to look at it.  This is the error when manually browsing from a local browser;
 
 HTTP Error 500.19 - Internal Server Error  The requested page cannot be accessed because the related configuration data for the page is invalid.   
   Detailed Error Information    ModuleIIS Web CoreNotificationBeginRequestHandlerNot yet determinedError Code0x80070021Config ErrorThis configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false". Config File\\?\C:\ProgramData\Codecore Technologies\Elve\WebSite\web.config    Requested URLhttp://localhost:33904/Physical PathC:\ProgramData\Codecore Technologies\Elve\WebSiteLogon MethodNot yet determinedLogon UserNot yet determined       Config Source    3:    <system.webServer>        4:       <handlers>        5:          <add name="j9sp" path="*.j9sp" verb="*" type="WebLibrary.J9SP_HttpHandler, WebLibrary" />   

John Hughes:
It sounds like you integrated Elve with IIS by adding the http handler for j9sp files.

Be sure the associated IIS application pool target .NET 2.0 and not 4.0.

Also be sure you have a bin directory in your web site path which includes the WebLibrary and other needed dlls.

I can give more details on these if you like but 1st make sure you have the .net version set right and at least have the dll files out in the bin folder.

DaveB:
John;  Well it looks like I have all of the above set correctly.  DLL's are in place, Web Cofiguration file is in place and looks correct, The site is set for .Net 2, The path looks correct. 
From the iPhone, I can not really tell what the issue is as it continually tries to reconnect.  From a browser session, I get the error that the browser is looking for the configuration file. 
 
See the attachments below..

John Hughes:
I installed Elve on a windows 7 machine and added an Application in the root web site and it simply worked the first time.

In IIS I right clicked the root "Default Web Site" node and selected "Add Application..." and used the following settings:

  Alias: ha
  Application Pool:  ASP.NET V2.0 (which is an integrated .net 2.0 pool for me)
  Physical path: C:\ProgramData\Codecore Technologies\Elve\WebSite

I then navigated to the following address and it worked the 1st time:

  http://localhost/ha/default.j9sp

You can ignore the "Authorization warning you see in IIS since I see that all the time in all websites.

By reading the error information from ASP.NET it looks like you have a configuration file set to disable the system.webServer / handlers section. Do you have any .config files in the parent directories of your application path?



DaveB:
John;
That is great that it worked for you.  I am not so lucky.  I deleted the old site and settings and started over as in your post.  I also checked that there is no additional configuration file in the root.  I now receive this error;
 
 HTTP Error 500.21 - Internal Server Error  Handler "j9sp" has a bad module "ManagedPipelineHandler" in its module list   
I will continue to try different things as time allows this week. 
 
 

Navigation

[0] Message Index

[#] Next page

Go to full version