Author Topic: Missing WebLibrary.dll and SharedLibrary.dll files  (Read 752 times)

ddavis1086

  • Newbie
  • *
  • Posts: 2
    • View Profile
Missing WebLibrary.dll and SharedLibrary.dll files
« on: July 07, 2011, 06:26:39 pm »
I am new to Elve and downloaded the pgm to test. I followed the install instructions and running on a fresh install of Windows XP Pro.
There are no other programs installed on the system other than Elve.

I am trying to look at the default Web Site and followed "configuring IIS for J9SP". The installer did not seem to install all of the files and that my be because of Windows XP Pro. I managed to get the virtual directory created in step one.

There was no "web.config" file in the web directory so I used the bare bones example although I am not sure what that does than point the the "WebLibarary" Handler. There was no "bin" directory so I created on and went to look for the "WebLibrary.dll and SharedLibrary.dll" files but did not find any. They were not in the C:\Program Files\Elve\ directory as step 3 indicated.

What should I do next and any idea what might have gone wrong for me?

Thanks for your help,

dennis


John Hughes

  • Administrator
  • Hero Member
  • *****
  • Posts: 2846
    • View Profile
    • Codecore Technologies
Re: Missing WebLibrary.dll and SharedLibrary.dll files
« Reply #1 on: July 08, 2011, 08:15:08 am »
Dennis,

The installer does not have the website nor the built in web server checked for installation by default. You must manually select them. I'm guessing you didn't have the web site files checkbox checked.

Elve includes a built in web server so if you choose to use it everything should be working immediately after the installation completes (and the services start up). However if you will be using the web server over the internet it is recommended that you use IIS for better security, etc. So if you prefer to use IIS you should only check the website files option.

You will need to run Setup.exe to uninstall Elve (you won't lose any configuration), then run it again to reinstall and select the appropriate options.
John Hughes
Codecore Technologies

ddavis1086

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Missing WebLibrary.dll and SharedLibrary.dll files
« Reply #2 on: July 08, 2011, 08:15:56 pm »
Hi and thank you for the reply.

I had tried several other HA programs and figured that one of them had done something to Win XP.
I reinstalled Win XP and then downloaded and reinstalled Elve. It works now.

Thank you,
dennis

John Hughes

  • Administrator
  • Hero Member
  • *****
  • Posts: 2846
    • View Profile
    • Codecore Technologies
Re: Missing WebLibrary.dll and SharedLibrary.dll files
« Reply #3 on: July 09, 2011, 10:58:10 am »
Great, thanks for the update. Please note that the majority of our users choose to use the touch screen viewer applications as opposed to the web browser. This is why it is not installed by default and also why we have not spent an a large amount of time putting together a high end sample web site.

We will likely move more of our resourses toward creating a Touch Screen Viewer application using Silverlight so that your touch screen interfaces can be viewed from a web browser. There is also a documented protocol for anyone who would like to create a 3rd party Silverlight or Flash application as well.
John Hughes
Codecore Technologies

mtnbound2011

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Missing WebLibrary.dll and SharedLibrary.dll files
« Reply #4 on: September 29, 2011, 06:07:23 pm »
I'm actually having the same issue, but I can't get the files to install even after uninstalling and reinstalling. I've even tried deleting all the folders after uninstall also.

I've tried both installing the built in webserver as well as installing IIS for my Windows 7 machine I'm testing with. The closest I get is trying to use the built in web server, but it tried to D/L the j9sp file instead of rendering it.

The installer installs the website files I think, but no web.config files. I also checked the c:\windows\assembly folder for the .dll files, but they weren't there either. I checked the Program Files directory as well, but there the files weren't there either.

I'm not looking for a fully featured web interface, but there are many times I'm away from the house, and I have an Android device.

Where should I look for the missing files. (I think the .dll's and the web.config)

Thank you

mtnbound2011

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Missing WebLibrary.dll and SharedLibrary.dll files
« Reply #5 on: September 30, 2011, 08:20:01 am »
OK. After much research, I finally got it working. I'm using IIS7 on Win7 pro.

I installed the new Elve version, and it installed the missing files. The next error I received was a 500.19, 0x80070021 error. After researching the error, it turns out that I need to unlock the handlers on my section so it can be used in web.config file.

This command takes care of that in anyone else has the same error: %windir%\system32\inetsrv\appcmd.exe unlock config -section:system.webServer/handlers

Work fine now.

John Hughes

  • Administrator
  • Hero Member
  • *****
  • Posts: 2846
    • View Profile
    • Codecore Technologies
Re: Missing WebLibrary.dll and SharedLibrary.dll files
« Reply #6 on: October 02, 2011, 10:20:22 pm »
Interesting, thanks for posting the information. I haven't seen locked handlers before.
John Hughes
Codecore Technologies

rnschltz

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Missing WebLibrary.dll and SharedLibrary.dll files
« Reply #7 on: March 14, 2012, 12:55:38 pm »
I have the same issue here running on Windows Home Server 2011. I have uninstalled/reinstalled the available trial version, but no /bin directory and no .dlls. Can these be added manually?


Nevermind...1.1.0.94 fixed this issue...

Thanks!
« Last Edit: March 14, 2012, 01:12:57 pm by rnschltz »