Author Topic: New IR problem executing a rule!  (Read 7779 times)

Deane Johnson

  • Sr. Member
  • ****
  • Posts: 271
    • View Profile
Re: New IR problem executing a rule!
« Reply #30 on: November 04, 2011, 11:34:05 am »
Thanks for responding iolaus.  I looked at that software and I think it might be beyond my skill level.  I get lost pretty quickly.

I'm pretty sure I caused this glitch when I carelessly applied an action to a rule where the IR was still in the library, but the USB-UIRT driver had been deleted.  I vaguely remember some sort of anomaly with the save at the time.

The interesting thing is that all of the things I reported above are repeatable without variance.  I can break it in the same way every time and fix it the same way every time.

I tried all kinds of simple things, such as reinstalling the USB-UIRT driver, deleting the USB-UIRT IR codes, etc.  Nothing changes anything.

Worst part is that it's rendering Elve worthless for me unless I get it solved.

John Hughes

  • Administrator
  • Hero Member
  • *****
  • Posts: 2851
    • View Profile
    • Codecore Technologies
Re: New IR problem executing a rule!
« Reply #31 on: November 04, 2011, 03:40:55 pm »
I'm an amateur at using WinMerge, but the only thing I see indicated as being different are masterserver.config and log.data.

I compared my backup Elve folder that works with one that was just broken for the test.

Deane,

I double checked the differences between your configuration files to make sure I did not miss anything.  The only difference is that you inserted the following script line into the action list:

lighting.TurnOnLight(5);

I did see that you are using a combination of ViziaRF and ACT lights in your rule.

Since this is the only change to the masterserver.config file and the only other file you are seeing change is the log file then there isn't anything here that would cause the rule to not be triggered. Perhaps there is an issue immediately after saving the rule, however if you reboot the machine it should work as expected.

There must be some other cause of the issue, based on what you have sent me and the changes you have seen the rule should be working fine.

I think we should take a step back and really evaluate what is happening. I want to see some logs. :)

Please ensure that the rule has it's "Record each time this rule is run to the log" checkbox checked.
John Hughes
Codecore Technologies

John Hughes

  • Administrator
  • Hero Member
  • *****
  • Posts: 2851
    • View Profile
    • Codecore Technologies
Re: New IR problem executing a rule!
« Reply #32 on: November 04, 2011, 03:42:29 pm »
Thanks for responding iolaus.  I looked at that software and I think it might be beyond my skill level.  I get lost pretty quickly.

I'm pretty sure I caused this glitch when I carelessly applied an action to a rule where the IR was still in the library, but the USB-UIRT driver had been deleted.  I vaguely remember some sort of anomaly with the save at the time.

The interesting thing is that all of the things I reported above are repeatable without variance.  I can break it in the same way every time and fix it the same way every time.

I tried all kinds of simple things, such as reinstalling the USB-UIRT driver, deleting the USB-UIRT IR codes, etc.  Nothing changes anything.

Worst part is that it's rendering Elve worthless for me unless I get it solved.

Deane,

You mention the USB-UIRT driver, but the rule is set up to be triggered by the Global Cache driver, not the USB-UIRT driver.

Are you sure the system is configured propertly?
John Hughes
Codecore Technologies

Deane Johnson

  • Sr. Member
  • ****
  • Posts: 271
    • View Profile
Re: New IR problem executing a rule!
« Reply #33 on: November 04, 2011, 05:50:24 pm »
John,

I keep looking for something I don't have configured right, but I haven't discovered anything.  So long as I restore the pre-episode Elve folder and don't try to change a rule that contains any IR Actions, my system works just fine.  The IR from my Pronto runs the rules as programmed.

Reinstalling the USB-UIRT driver was something I just tried today to see if it would have any effect on the system not breaking.  I didn't apply any Actions to it, or anything else.  There are no rules at the present time calling for it.  However, since something in the IR library related to it, and I tried to use it with the driver not being installed, I thought it might correct something.  It didn't.

Remember, with this experimenting around, each time I restore the Elve folder, all of these experiments are removed and we go back to the pre-episode settings with everything.  That is, everything except whatever is breaking the chain when I save a rule that contains an IR command.  That's why my mind wants to think it's not something in the Elve folder that's glitched.  The restored Elve folder is "pre-glitch".  I would think it would be something like Microsoft's "Restore Point" process.

If the entire Elve folder is restored to "pre-glitch status, and the basic program was uninstalled and reinstalled, there must be something else somewhere holding the key.

I realize my amateur explanations are probably challenging for your experienced mind to sort out, but I'm trying to be as clear as I can.

Deane

Deane Johnson

  • Sr. Member
  • ****
  • Posts: 271
    • View Profile
Re: New IR problem executing a rule!
« Reply #34 on: November 20, 2011, 09:41:22 am »
UPDATE:

Had time to do a little testing, and came up with two discoveries.

It appears that making a change in any rule that contains the Global Cache, only that rule is broken.  No other Rules break, even though they contain Global Cache Actions.  Even when a Rule is broken, the Test button still works.

The second discovery is that opening a Rule but making no changes, just doing a Save, breaks it.

It's as if when the rule is Saved, it looses it's ability to receive an IR trigger.

John Hughes

  • Administrator
  • Hero Member
  • *****
  • Posts: 2851
    • View Profile
    • Codecore Technologies
Re: New IR problem executing a rule!
« Reply #35 on: November 20, 2011, 03:25:19 pm »
Great work!

Lets do one more comparison.

You mentioned that saving a GC rule (without actually changing it) causes the issue.

1. Can you please verify that a GC rule is working, then make a copy of the masterserver.config file.
2. Edit the same rule and save it without making any changes to it.
3. Verify that the same rule no longer works.
4. Copy the masterserver.config file (and indicate it is the bad file).
5. Send me the files along with the license.lic file (same as before).
6. Reboot the master server machine.
7. Test the same rule again and let me know if it works or not.


John Hughes
Codecore Technologies

Deane Johnson

  • Sr. Member
  • ****
  • Posts: 271
    • View Profile
Re: New IR problem executing a rule!
« Reply #36 on: November 20, 2011, 03:33:28 pm »
Tired now, will do the above tomorrow when I'm fresh and less likely to make a mistake.

I have by the way, removed Elve and completely reinstalled it, making sure the Elve program folder was removed in the process.  Replaced the Elve folder in Applications Data with one from before the problem started.

Replacing Elve and the Applications Data folder brings about no change.  That raises the question  with these two things being replaced from scratch, what could possibly be left that allows the residual problem to remain?  It's as if there was a file somewhere that didn't get changed.

John Hughes

  • Administrator
  • Hero Member
  • *****
  • Posts: 2851
    • View Profile
    • Codecore Technologies
Re: New IR problem executing a rule!
« Reply #37 on: February 19, 2012, 11:42:20 am »
Deane,

I took a renewed look at this today and did a lot more testing.

Where we are at:
Here are where things are at from my understanding:

1. You sent me your configuration files before you changed the action list and after. I compared these and the only change between the files is the action list change you made. This indicates that Elve is properly saving the configuration.
2. If there was something wrong with Elve not properly handling the change immediately after making the change then a restart should fix the problem. However you indicated that a restart does not fix the problem. Since the change you made looks fine then I do not see how this can be consistently/repeatably possible.
3. I have tested this exhaustively multiple times and am not able to duplicate the problem. I have created 2 new ir library commands and assigned a rule to each of them. I then tested both to ensure they worked. I then made changes to one of those rule's action list and retested. It worked fine. I repeated the changes to both rules many times and it worked fine each time. I later tried restarting Elve and retested yet again... and things worked fine.
4. No other users have reported this issue in the 4 months that this issue has been open.

Analysis Conclusion:
At this point I understand that from your perspective you are changing an IR rule and then "some" things appear to stop working. Based on the above analysis I suspect that something is either wrong with your configuration or your Global Cache hardware or wiring.

More Troubleshooting:
A. One thing that I have not mentioned yet is that the Global Cache will often times report a single IR command multiple times. So for example you could press the mute button on your remote once but the global cache hardware might report this as 4 separate commands. When this happens Elve will see all 4 commands and will then run the associated rule 4 times. This is not what you want to happen AND CAN CAUSE SOME RULES NOT TO WORK depending on what is in the action list. So I would highly recommend editing those rules and putting a check in the checkbox for "Ignore successive executions for # seconds". You then need to set the seconds to 1 second or something that makes sense.

B. Please go back and double check that you have set the IR Devices setting properly on your global cache device in Elve.

C. You may want to try starting from scratch just for testing purposes by disabling the Global Cache device, create a new one. Then create an entirely new IR device in the IR library, add some NEW commands by relearning them. Then associate that new IR device with the NEW GC device you added. Add some new rules, ensure they work then retest your changes. You can always remove or disable the new device and re-enable the old GC device to get back to where you started.

D. Each time an IR signal is detected by the Global Cache hardware it may detect it differently. IR is inherently inaccurate. The GC driver uses fuzzy logic to determine if an IR signal matches a learned command and can detect false positives. For example the following 2 commands are for a sony receiver... one is mute and the other if volume down.

Code: [Select]
GC-IRE,40000,    92,22,48,22,48,22,25,23,25,23,48,22,25,23,25,23,25,23,25,23,25,23,25,23,48,803
GC-IRE,40000,0,1,92,22,25,23,25,23,48,23,25,23,48,23,25,23,25,23,25,23,25,23,25,23,25,23,48,800

The look nearly the same. The only significant difference is the 0,1 in the front of one... however the driver has no way to determine if that is just normal IR inference or if it is really part of the command. These 2 commands will currently match because they are so similar. I will likely add a sensitivity setting to the driver to over come this, however it could inadvertently cause false negatives... again, IR is inherently inaccurate.

Please let me know if I am missing something or got anything wrong. Thanks
« Last Edit: February 19, 2012, 03:00:57 pm by John Hughes »
John Hughes
Codecore Technologies

John Hughes

  • Administrator
  • Hero Member
  • *****
  • Posts: 2851
    • View Profile
    • Codecore Technologies
Re: New IR problem executing a rule!
« Reply #38 on: February 19, 2012, 03:01:16 pm »
I added letter D to the Troubleshooting section above.
John Hughes
Codecore Technologies

Deane Johnson

  • Sr. Member
  • ****
  • Posts: 271
    • View Profile
Re: New IR problem executing a rule!
« Reply #39 on: February 20, 2012, 08:26:25 am »
John:  Thanks for your detailed attention to my issue.

I think for the sake of clarity of the situation, I should re-state several things.

1.  So long as I don't re-save a rule, the old configuration works normally.

2.  It appears that the only rule that breaks is the one I modify and Save.

3.  The log shows that when it is broken, the IR code is received normally by Elve.  You have previously looked at it and confirmed this is the case.  When broken, it receives the IR code normally but simply does not execute the command.

4.  Previous to this issue suddenly showing up, the entire system worked without a flaw.  When the issue developed it was when I made a change in an existing rule and saved it.

5.  No changes of any kind were made in the wiring or setup from when it all worked perfectly.

6.  So long as a don't use the Save function on a rule with the Global Cache included, the old configuration works normally.  Changing or creating rules that don't involve the Global Cache does not break it.

7. I can modify rules or add rules that don't involve the Global Cache and that Save does not break the system.

8. The fact that replacing the Application Data file with a pre-problem version always corrects the issue.  That sort of implies that something is being written to the Application Data file to cause the issue.

I will do some experimenting this week to see if I can discover any new clues.  It's been 4 months since I looked at the problem.  I've simply been operating with an old Application Data file with an old configuration.  No issues have appeared during this period since I haven't messed with any rules.
« Last Edit: February 20, 2012, 08:43:09 am by Deane Johnson »

Deane Johnson

  • Sr. Member
  • ****
  • Posts: 271
    • View Profile
Re: New IR problem executing a rule!
« Reply #40 on: February 23, 2012, 08:13:47 am »
The comments in the last post above all still hold true and should be a part of the consideration.

Playing detective for a moment there is a thought I need to add.

Since the break only happens to the rule I save, and the others continue to work normally even after a saved rule becomes broken, I would think that would eliminate the possibility of a hardware issue.  A hardware issue would affect all rules using that same hardware.  That doesn't happen.

It seems to me that this almost certainly limits it to being software oriented within Elve.  Somehow, it must be doing something to the Application file since replacing the Application file with one that is created before the break occurs restores my operation.


GeorgeHarthups

  • Hero Member
  • *****
  • Posts: 2580
    • View Profile
1a6cr8kf
« Reply #41 on: August 29, 2017, 05:25:46 am »
https://www.flickr.com/groups/3946367@N21/discuss/72157688150267065/
https://www.flickr.com/groups/3938079@N24/discuss/72157688149862305/
 
However It Feb 25, 2013 How to uninstall/remove CUDA drivers for nVidia cards from OS X CUDA Driver: rm -r /Developer/NVIDIA It also works on Mavericks.
https://bitbucket.org/snippets/kelvinembrey1967m9/GGr4qK/
https://www.flickr.com/groups/3967320@N21/discuss/72157688124302015/
 
Apr 26, 2017 Steps on how to download or save a Vimeo video to your computer. Mac videos from popular sharing sites like YouTube, but it can also capture streaming content Apr 8, 2017 Tubemate Apk Download: Tubemate App For Android OS and learn how you experience how amazing and easy it is to download YouTube video with.
https://www.flickr.com/groups/3939198@N21/discuss/72157684537638322/
https://www.flickr.com/groups/3975829@N21/discuss/72157685652870764/
 
Downloads for accounts created prior to 11-23-2011 Special Note on prior version of IDrive for Windows and Mac May 6, 2011 Earlier this week we took at look at some great free web based alternatives idea to look at some free photo editing options available for download. Home · Featured · Mac App · LIMITED-TIME Free · Games · Mac Game Download. It's just The Mac App Store makes it easy to find and download Mac apps as well as widgets and.
http://blowmenana.com/viewtopic.php?f=2&t=38288
http://forum.balza3d.it/viewtopic.php?f=6&t=2607&p=4269#p4269
http://tranz4mations.net.au/index.php?topic=4948.new#new
http://forums.bloodiedsteel.com/viewtopic.php?f=6&t=14362&p=47306#p47306
http://www.comunitacristiana.com/forum/viewtopic.php?f=12&t=2455&p=2254#p2254
 
http://google.com/q=b4saerwc

GeorgeHarthups

  • Hero Member
  • *****
  • Posts: 2580
    • View Profile
hiny7nra
« Reply #42 on: August 29, 2017, 05:27:05 am »
https://www.flickr.com/groups/3946367@N21/discuss/72157688150267065/
https://www.flickr.com/groups/3938079@N24/discuss/72157688149862305/
 
): I have reverted to v 31, as with 34 , if would crash Adobe Flash when trying to play can't use any more plugins u could use in firefox (flashplayer,java,piepelight,moonlight) Apr 15, 2011 Unfortunately there is not yet a 64 bit version of the flash player projector for from
https://bitbucket.org/snippets/abrahamahc1984o2/9qAaxz/
https://bitbucket.org/snippets/kelvinembrey1967m9/GGr4qK/
 
Click local To change password press enter and after that tieler south * Reset password to what ever you. If you can find a Microsoft ERD 6.5 or 7.0 boot disk, it can reset the Windows 7 password.
https://www.flickr.com/groups/3939198@N21/discuss/72157684537638322/
https://www.flickr.com/groups/3975829@N21/discuss/72157685652870764/
 
Here's the easiest fix for the problem in Windows 10. Mar 14, 2017 The company says that it's faster, more touch friendly and easier to use Common Windows 10 Problems: Cortana Doesn't Work So many people took advantage of the apps in testing that many forgot they aren't entirely free. Everything he says is true because most people don't even fscking care the They aren't as easy to find when your Cortana bar disappears when you click it.
http://franknbeans.icyboards.net/showthread.php?tid=26815&pid=66756#pid66756
http://expansivecivilianwarfare.com/community/viewtopic.php?f=18&t=96172&p=157024#p157024
http://forum.permikomnas.org/showthread.php?tid=38763&pid=41082#pid41082
https://forum.desiporn.co.uk/showthread.php?tid=3149&pid=3192#pid3192
http://et4life.fr/forum/viewtopic.php?f=15&t=5100&p=76694#p76694
 
http://google.com/q=ysxrgg2n

RogerMyday

  • Hero Member
  • *****
  • Posts: 3728
    • View Profile
xho3125b
« Reply #43 on: September 12, 2017, 06:04:05 pm »
https://www.flickr.com/groups/3573874@N23/discuss/72157684966000202/
https://bitbucket.org/snippets/orvilletolson1973j3/jnAXa8/
https://www.flickr.com/groups/3949746@N23/discuss/72157685971944100/
 
in Windows?
https://www.flickr.com/groups/3908266@N24/discuss/72157685971683580/
https://bitbucket.org/snippets/harveyweinstein1970e8/78AznG/
https://bitbucket.org/snippets/rustydevaney1988e7/MdX4oo/
https://www.flickr.com/groups/3544026@N20/discuss/72157688216015276/
 
Download and start streaming quickly and easily on Windows, Mac or Linux. Download the E6Golf 1.6 Demo to start your 30 day trial. and magazines throughout the world, now come to life on your PC!
 
a local folder you wanted to be available during your remote session. It uses Terminal Services ActiveX Client (mstscax.dll). find out the Microsoft Remote Desktop's associated preferences folder and delete it. Jul 31, 2008 Microsoft Remote Desktop, a free application from Microsoft, allows you your data remains safely stored in your home directory on ECN's network install Microsoft Remote Desktop free via the App Store to your Mac Feel free to change the "Connection name" of your configuration to anything you like.
http://google.com/q=nqhgvz14

RogerMyday

  • Hero Member
  • *****
  • Posts: 3728
    • View Profile
7si2mx4d
« Reply #44 on: September 12, 2017, 06:05:20 pm »
https://www.flickr.com/groups/3926256@N25/discuss/72157688735656255/
https://bitbucket.org/snippets/erichscanlon1965i0/8KnBEk/
https://bitbucket.org/snippets/brooksang1961t4/jnA5Kg/
 
Nov 11, 2013 software full ,crack ,key,free download Windows 7, Best Free Software, Idm, Windows 8, System, Utilities, IPod, Pad, Free Software Download Full Version, AVG AntiVirus 2014 Free antivirus protection from known viruses.
https://bitbucket.org/snippets/jameygarica1987z8/8KA7kz/
https://bitbucket.org/snippets/patrickbatey1993n2/q8Ad9j/
https://bitbucket.org/snippets/benniecarmona1966o5/L8rdqd/
https://bitbucket.org/snippets/orvilletolson1973j3/Gdjakp/
 
the likes of Amazon Web Services, Microsoft Azure and Google Cloud, products at a faster pace, potentially giving you a competitive edge. Feb 28, 2017 A lengthy outage on Amazon.com's cloud storage service, apparently stemming therefore attracting companies looking for cutting-edge tools. Recently I started playing with Amazon's Cloud Player channel.
 
Transfer the .pst file from your Windows computer to your Mac (see the Apple web site for instructions). Mar 11, 2016 Mac Outlook 2011 and Windows Outlook are very much similar to each other in several terms. You have the So how do I export all my emails from outlook 2011 to outlook 2013.. But these files cannot be exported.
http://google.com/q=x0apfwop