Developer Center > Third Party Communication Protocols

HTTP API issue - Command running unpredictably

(1/4) > >>

iostream212:
Background:
I have a few scenes in Elve that work perfectly. My trouble started when I wanted to activate those scenes using my ISY.
I decided to do so by using the HTTP API and the ISY networking module. Below is an example of the network resource I created:

I tested it in ISY and the scene runs as expected.
Next I created some programs in ISY to manually execute the scene

--- Code: ---If
   - No Conditions - (To add one, press 'Schedule' or 'Condition')
 
Then
        Resource 'Master TV On'
 
Else
   - No Actions - (To add one, press 'Action')

--- End code ---
I run the 'then' path and the scene activates as expected. Notice there are no conditions in this program. It requires manual execution.

Forward to now. This scene is running by itself at all hours of the night. I don't understand how it is being triggered. Here is a screen shot of my log:

ISY log is not showing the program running at all.
What is going on? Thanks!

bpwwer:
Just a thought ...

Are you sure the ISY isn't running the program?  Because you have no condition, it may be running it any  time it gets re-evaluated.  If you look at the ISY program summary page, it shows the last time the program was run.  Does that match with the last time the scene was activated in Elve?

You could disable the program on the ISY to make sure it isn't getting run.  I think you can still manually run it even when it is disabled.

iostream212:
Hi,
Thanks for the reply. I didn't think that it was the ISY just because the program last run time didn't match the Elve logs. In fact the last run time on ISY was far earlier than the run times logged in Elve. And to be honest I am not 100% on how programs are evaluated in ISY. It would make sense that it is an ISY issue because this never started until I added the Elve scenes as a ISY resource.

iostream212:
I posted over on ISY forums. Seems they started a topic on unpredictable program behavior.

Sent from my SCH-I510 using Tapatalk

bpwwer:
Did you try disabling the program on the ISY to see if the behavior stops?

It does seem more likely that the ISY would be running the program than Elve would be randomly triggering the scene.

Navigation

[0] Message Index

[#] Next page

Go to full version